BGP with IPv6 Addresses. Injecting BGP routes in OSPF

  • 0
AIRTEL#sh run
Building configuration...

Current configuration : 2581 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname AIRTEL
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip source-route
no ip icmp rate-limit unreachable
!
!
!
!
ip cef
no ip domain lookup
ipv6 unicast-routing
no ipv6 traffic interface-statistics
ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Ethernet0/0
 description "IKF_CORE"
 ip address 1.4.0.1 255.255.255.252
 ipv6 address 2401:AF:1:1:1:1:1:1/126
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Ethernet1/0
 no ip address
 shutdown
!
interface Ethernet1/1
 no ip address
 shutdown
!
interface Ethernet1/2
 no ip address
 shutdown
!
interface Ethernet1/3
 no ip address
 shutdown
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/3
 no ip address
 shutdown
 serial restart-delay 0
!
router bgp 1400
 bgp log-neighbor-changes
 neighbor 1.4.0.2 remote-as 1300
 neighbor 1.4.0.2 description IKF_CORE
 neighbor 2401:AF:1:1:1:1:1:2 remote-as 1300
 !
 address-family ipv4
  no synchronization
  neighbor 1.4.0.2 activate
  neighbor 2401:AF:1:1:1:1:1:2 activate
  no auto-summary
 exit-address-family
 !
 address-family ipv6
  network 2401:AF:1:1::/64
  network 2401:AF:1:2::/64
  network 2401:AF:1:3::/64
  network 2401:AF:1:4::/64
  neighbor 2401:AF:1:1:1:1:1:2 activate
  neighbor 2401:AF:1:1:1:1:1:2 soft-reconfiguration inbound
 exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ipv6 route 2401:AF:1:1::/64 Null0
ipv6 route 2401:AF:1:2::/64 Null0
ipv6 route 2401:AF:1:3::/64 Null0
ipv6 route 2401:AF:1:4::/64 Null0
!
!
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
exception data-corruption buffer truncate
end

AIRTEL#

AIRTEL#sh bgp ipv6 unicast neighbors 2401:AF:1:1:1:1:1:2 received-routes
BGP table version is 9, local router ID is 1.4.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
*> 2404:CF40:1::/64 2401:AF:1:1:1:1:1:2
                                             0             0 1300 i
*> 2404:CF40:2::/64 2401:AF:1:1:1:1:1:2
                                             0             0 1300 i
*> 2404:CF40:3::/64 2401:AF:1:1:1:1:1:2
                                             0             0 1300 i
*> 2404:CF40:4::/64 2401:AF:1:1:1:1:1:2
                                             0             0 1300 i
Total number of prefixes 4
AIRTEL#sh bgp ipv6 unicast neighbors 2401:AF:1:1:1:1:1:2 advertised-routes
BGP table version is 9, local router ID is 1.4.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Originating default network ::/0
   Network          Next Hop            Metric LocPrf Weight Path
*> 2401:AF:1:1::/64 ::                       0         32768 i
*> 2401:AF:1:2::/64 ::                       0         32768 i
*> 2401:AF:1:3::/64 ::                       0         32768 i
*> 2401:AF:1:4::/64 ::                       0         32768 i
Total number of prefixes 4
AIRTEL#



IKF_CORE#sh run
Building configuration...

Current configuration : 2922 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname IKF_CORE
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip source-route
no ip icmp rate-limit unreachable
!
!
 --More--
*Apr 26 16:07:31.791: %SYS-5-CONFIG_I: Configured from console by console
!
!
ip cef
no ip domain lookup
ipv6 unicast-routing
no ipv6 traffic interface-statistics
ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
 ip address 1.3.0.1 255.255.255.255
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface Ethernet0/0
 ip address 1.3.1.1 255.255.255.252
 ip ospf 1 area 0
 ipv6 address 2404:CF40:1:1:1:1:1:1/126
 ipv6 ospf 1 area 0
!
interface Ethernet0/1
 description AIRTEL
 ip address 1.4.0.2 255.255.255.252
 ipv6 address 2401:AF:1:1:1:1:1:2/126
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Ethernet1/0
 no ip address
 shutdown
!
interface Ethernet1/1
 no ip address
 shutdown
!
interface Ethernet1/2
 no ip address
 shutdown
!
interface Ethernet1/3
 no ip address
 shutdown
!
interface Serial2/0

IKF_CORE#
IKF_CORE#sh run
Building configuration...

Current configuration : 2922 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname IKF_CORE
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip source-route
no ip icmp rate-limit unreachable
!
!
!
!
ip cef
no ip domain lookup
ipv6 unicast-routing
no ipv6 traffic interface-statistics
ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
 ip address 1.3.0.1 255.255.255.255
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface Ethernet0/0
 ip address 1.3.1.1 255.255.255.252
 ip ospf 1 area 0
 ipv6 address 2404:CF40:1:1:1:1:1:1/126
 ipv6 ospf 1 area 0
!
interface Ethernet0/1
 description AIRTEL
 ip address 1.4.0.2 255.255.255.252
 ipv6 address 2401:AF:1:1:1:1:1:2/126
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Ethernet1/0
 no ip address
 shutdown
!
interface Ethernet1/1
 no ip address
 shutdown
!
interface Ethernet1/2
 no ip address
 shutdown
!
interface Ethernet1/3
 no ip address
 shutdown
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 log-adjacency-changes detail
 redistribute bgp 1300
!
router bgp 1300
 bgp log-neighbor-changes
 neighbor 1.4.0.1 remote-as 1400
 neighbor 2401:AF:1:1:1:1:1:1 remote-as 1400
 neighbor 2401:AF:1:1:1:1:1:1 description AIRTEL
 !
 address-family ipv4
  no synchronization
  neighbor 1.4.0.1 activate
  neighbor 2401:AF:1:1:1:1:1:1 activate
  no auto-summary
 exit-address-family
 !
 address-family ipv6
  network 2404:CF40:1::/64
  network 2404:CF40:2::/64
  network 2404:CF40:3::/64
  network 2404:CF40:4::/64
  neighbor 2401:AF:1:1:1:1:1:1 activate
  neighbor 2401:AF:1:1:1:1:1:1 soft-reconfiguration inbound
 exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ipv6 route 2404:CF40:1::/64 Null0
ipv6 route 2404:CF40:2::/64 Null0
ipv6 route 2404:CF40:3::/64 Null0
ipv6 route 2404:CF40:4::/64 Null0
ipv6 router ospf 1
 log-adjacency-changes
 redistribute bgp 1300
!
!
!
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
exception data-corruption buffer truncate
end

IKF_CORE#

IKF_CORE#sh ipv6 route
IPv6 Routing Table - default - 14 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external, ND - Neighbor Discovery
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B   2401:AF:1:1::/64 [20/0]
     via FE80::A8BB:CCFF:FE00:400, Ethernet0/1
C   2401:AF:1:1:1:1:1:0/126 [0/0]
     via Ethernet0/1, directly connected
L   2401:AF:1:1:1:1:1:2/128 [0/0]
     via Ethernet0/1, receive
B   2401:AF:1:2::/64 [20/0]
     via FE80::A8BB:CCFF:FE00:400, Ethernet0/1
B   2401:AF:1:3::/64 [20/0]
     via FE80::A8BB:CCFF:FE00:400, Ethernet0/1
B   2401:AF:1:4::/64 [20/0]
     via FE80::A8BB:CCFF:FE00:400, Ethernet0/1
S   2404:CF40:1::/64 [1/0]
     via Null0, directly connected
C   2404:CF40:1:1:1:1:1:0/126 [0/0]
     via Ethernet0/0, directly connected
L   2404:CF40:1:1:1:1:1:1/128 [0/0]
     via Ethernet0/0, receive
O   2404:CF40:1:1:1:1:1:8/126 [110/20]
     via FE80::A8BB:CCFF:FE00:100, Ethernet0/0
S   2404:CF40:2::/64 [1/0]
     via Null0, directly connected
S   2404:CF40:3::/64 [1/0]
     via Null0, directly connected
S   2404:CF40:4::/64 [1/0]
     via Null0, directly connected
L   FF00::/8 [0/0]
     via Null0, receive
IKF_CORE#


IKF_AGGREGATION#sh run
Building configuration...

Current configuration : 2191 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname IKF_AGGREGATION
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip source-route
no ip icmp rate-limit unreachable
!
!
!
!
ip cef
no ip domain lookup
ipv6 unicast-routing
no ipv6 traffic interface-statistics
ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
 ip address 1.3.0.2 255.255.255.255
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface Ethernet0/0
 ip address 1.3.1.2 255.255.255.252
 ip ospf 1 area 0
 ipv6 address 2404:CF40:1:1:1:1:1:2/126
 ipv6 ospf 1 area 0
!
interface Ethernet0/1
 ip address 1.3.1.5 255.255.255.252
 ip ospf 1 area 0
 ipv6 address 2404:CF40:1:1:1:1:1:9/126
 ipv6 ospf 1 area 0
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Ethernet1/0
 no ip address
 shutdown
!
interface Ethernet1/1
 no ip address
 shutdown
!
interface Ethernet1/2
 no ip address
 shutdown
!
interface Ethernet1/3
 no ip address
 shutdown
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 log-adjacency-changes detail
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ipv6 router ospf 1
 log-adjacency-changes
!
!
!
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
exception data-corruption buffer truncate
end

IKF_AGGREGATION#


IKF_AGGREGATION#sh ipv6 route
IPv6 Routing Table - default - 9 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external, ND - Neighbor Discovery
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
OE2 2401:AF:1:1::/64 [110/1]
     via FE80::A8BB:CCFF:FE00:200, Ethernet0/0
OE2 2401:AF:1:2::/64 [110/1]
     via FE80::A8BB:CCFF:FE00:200, Ethernet0/0
OE2 2401:AF:1:3::/64 [110/1]
     via FE80::A8BB:CCFF:FE00:200, Ethernet0/0
OE2 2401:AF:1:4::/64 [110/1]
     via FE80::A8BB:CCFF:FE00:200, Ethernet0/0
C   2404:CF40:1:1:1:1:1:0/126 [0/0]
     via Ethernet0/0, directly connected
L   2404:CF40:1:1:1:1:1:2/128 [0/0]
     via Ethernet0/0, receive
C   2404:CF40:1:1:1:1:1:8/126 [0/0]
     via Ethernet0/1, directly connected
L   2404:CF40:1:1:1:1:1:9/128 [0/0]
     via Ethernet0/1, receive
L   FF00::/8 [0/0]
     via Null0, receive
IKF_AGGREGATION#

IKF_AGGREGATION#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route
Gateway of last resort is not set
      1.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O        1.3.0.1/32 [110/11] via 1.3.1.1, 02:34:42, Ethernet0/0
C        1.3.0.2/32 is directly connected, Loopback0
O        1.3.0.3/32 [110/11] via 1.3.1.6, 04:01:58, Ethernet0/1
C        1.3.1.0/30 is directly connected, Ethernet0/0
L        1.3.1.2/32 is directly connected, Ethernet0/0
C        1.3.1.4/30 is directly connected, Ethernet0/1
L        1.3.1.5/32 is directly connected, Ethernet0/1
IKF_AGGREGATION#


IKF_DISTRIBUTION#sh run
Building configuration...

Current configuration : 2174 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname IKF_DISTRIBUTION
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip source-route
no ip icmp rate-limit unreachable
!
!
!
!
ip cef
no ip domain lookup
ipv6 unicast-routing
no ipv6 traffic interface-statistics
ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
 ip address 1.3.0.3 255.255.255.255
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface Ethernet0/0
 ip address 1.3.1.6 255.255.255.252
 ip ospf 1 area 0
 ipv6 address 2404:CF40:1:1:1:1:1:A/126
 ipv6 ospf 1 area 0
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Ethernet1/0
 no ip address
 shutdown
!
interface Ethernet1/1
 no ip address
 shutdown
!
interface Ethernet1/2
 no ip address
 shutdown
!
interface Ethernet1/3
 no ip address
 shutdown
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 log-adjacency-changes detail
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ipv6 route 2404:CF40:1:1:1:1:1:0/126 Ethernet0/0 2404:CF40:1:1:1:1:1:9
ipv6 router ospf 1
 log-adjacency-changes
!
!
!
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
exception data-corruption buffer truncate
end

IKF_DISTRIBUTION#


IKF_DISTRIBUTION#sh ip rou
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route
Gateway of last resort is not set
      1.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
O        1.3.0.1/32 [110/21] via 1.3.1.5, 02:35:13, Ethernet0/0
O        1.3.0.2/32 [110/11] via 1.3.1.5, 04:02:30, Ethernet0/0
C        1.3.0.3/32 is directly connected, Loopback0
O        1.3.1.0/30 [110/20] via 1.3.1.5, 04:02:30, Ethernet0/0
C        1.3.1.4/30 is directly connected, Ethernet0/0
L        1.3.1.6/32 is directly connected, Ethernet0/0
IKF_DISTRIBUTION#sh ipv6 route
IPv6 Routing Table - default - 8 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external, ND - Neighbor Discovery
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
OE2 2401:AF:1:1::/64 [110/1]
     via FE80::A8BB:CCFF:FE00:110, Ethernet0/0
OE2 2401:AF:1:2::/64 [110/1]
     via FE80::A8BB:CCFF:FE00:110, Ethernet0/0
OE2 2401:AF:1:3::/64 [110/1]
     via FE80::A8BB:CCFF:FE00:110, Ethernet0/0
OE2 2401:AF:1:4::/64 [110/1]
     via FE80::A8BB:CCFF:FE00:110, Ethernet0/0
S   2404:CF40:1:1:1:1:1:0/126 [1/0]
     via 2404:CF40:1:1:1:1:1:9, Ethernet0/0
C   2404:CF40:1:1:1:1:1:8/126 [0/0]
     via Ethernet0/0, directly connected
L   2404:CF40:1:1:1:1:1:A/128 [0/0]
     via Ethernet0/0, receive
L   FF00::/8 [0/0]
     via Null0, receive
IKF_DISTRIBUTION#sh ipv6 osp
IKF_DISTRIBUTION#sh ipv6 ospf ne
IKF_DISTRIBUTION#sh ipv6 ospf neighbor
Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
1.3.0.2           1   FULL/BDR        00:00:31    4               Ethernet0/0
IKF_DISTRIBUTION#




VLANs in Huawei

  • 0
Setting name and setting description is different.
If
dis vlan 101
is run, the output will show the description and not the name.
Alternatively you can find the status of a VLAN using its name:
dis vlan vlan-name NAGPUR


Clear vSphere Connection History

Open this section in Registry Editor and Clear the Entries shown in the Snap:
HKEY_CURRENT_USER\Software\VMware\VMware Infrastructure Client\Preferences


Cisco TechNotes

  • 0

What is the difference between the two methods to create static routes?

There are two methods to create static routes:

The ip route 10.1.1.1 255.255.255.0 eth 0/0 command generates an ARP broadcast that looks for the next-hop IP address.
The ip route 10.1.1.1 255.255.255.0 172.16.1.1 command does not generate an ARP request. It keeps Layer 2 out of the routing process.

General Debugging Commands:

  • term len 0

terminal length

To set the number of lines of output to display on the terminal screen for the current session before pausing, use the terminal length command. To revert to the default, use the no form of this command.
terminal length lines
terminal no length

Syntax Description

lines
Number of lines to display. The range is from 0 to 511. Use 0 to not pause while displaying output.
https://www.cisco.com/c/m/en_us/techdoc/dc/reference/cli/nxos/commands/fund/terminal-length.html

  • term exec prompt timestamp
  • show ver
  • show inv
  • show log
  • show platform
  • show platform software process list R0 sort mem

  • show platform software status control-processor brief

  • show platform software memory messaging chassis-manager 0

Building a DNS using Bind on Ubuntu

zone "13.8.10.in-addr.arpa" {
        type master;
        file "/etc/bind/db.13";
};

$TTL    604800
@       IN      SOA     example.co.in. root.example.co.in. (
                        2252019         ; Serial
                         604800         ; Refresh
                          86400         ; Retry
                        2419200         ; Expire
                         604800 )       ; Negative Cache TTL
;
@       IN      NS      ns1.example.co.in.
@       IN      A       10.88.13.11
ns1     IN      A       10.88.13.10
 zone "example.co.in" {
type master;
file "/etc/bind/db.example.co.in";
};
$TTL 86400
@ IN SOA ns1.example.in. root.example.co.in.(
                20191 ; serial
                28800 ; refresh
                14400 ; retry
                36000 ; expire
                86400); default_ttl
@     IN NS  ns1
ns1   IN A   10.8.13.10
10    IN PTR ns1.example.co.in.
29    IN PTR  www.example.co.in.
1   IN PTR reverse.1.13.8.10.example.co.in.

allow-query     { any; };
recursion yes;
allow-query-cache { any; };
allow-recursion{ any; };
filter-aaaa-on-v4 yes;

logging{
channel simple_log {
file "/var/cache/bind/bind.log" versions 3 size 5m;
severity warning;
print-time yes;
print-severity yes;
print-category yes;
};
category default {
simple_log;
};
channel query_log {
file "/var/cache/bind/bind-queries.log";
print-category yes;
print-time yes;
};
category queries {
query_log;
};
};

Google Caching


Following are some key points to remember from Google's perspective when deploying GCC in ISP Network:

Please be aware that advertising a prefix to a GGC node makes the node a candidate to serve users behind that prefix. It does not guarantee that the GGC node will be selected as the best location to serve that prefix.

When Google have multiple paths available to serve a prefix, the "best" one is continuously re-calculated.

The calculation is based primarily on prefix-specificity, AS-path length and RTT. A number of other factors will also be considered, including current GGC loading, and the quality of the network paths between the GGC node and it's users.

Google rely on our GGC partners to make appropriate prefix announcements to the node(s) they host, and do not intervene in discussions about the propriety of individual advertisements.


https://support.google.com/interconnect/answer/7658596?hl=en&ref_topic=7650153
https://support.google.com/interconnect/answer/7658603?hl=en&ref_topic=7659203

ISP Portal: https://isp.google.com/
ISP Help Center: https://support.google.com/interconnect/

What does it mean to have fast or autonomous switching "enabled" and "disabled" on the same interface ?

Look at the above snap ^

If you enable fast or autonomous switching on an interface, packets coming from any other interface on the router are fast-switched (or autonomous-switched) to that interface. If you enable same-interface fast or autonomous switching, packets whose source and destination address are the same are fast or autonomous switched. You can use same-interface fast or autonomous switching in cases where you have Frame Relay or Asynchronous Transfer Mode (ATM) WAN links configured as subinterfaces on the same main interface. Another situation is when you are using secondary networks on LAN interfaces, as during IP address migration. In order to enable same-interface fast switching, use the ip route-cache same-interface configuration command.

Fast Switching:-

Fast switching is an improvement over process switching. The first packet of a new session is copied to the interface processor buffer. The packet is then copied to the CxBus (or other backplane technology as appropriate to the platform) and sent to the switch processor. A check is made against other switching caches (for example, silicon or autonomous) for an existing entry.

Fast switching is then used because no entries exist within the more efficient caches. The packet header is copied and sent to the route processor, where the fast-switching cache resides. Assuming that an entry exists in the cache, the packet is encapsulated for fast switching and sent back to the switch processor. Then the packet is copied to the buffer on the outgoing interface processor, and ultimately it is sent out the destination interface.

Fast switching is on by default for lower-end routers like the4000/2500 series and may be used on higher-end routers as well. It is important to note that diagnostic processes sometimes require reverting to process switching. Fast-switched packets will not traverse the route processor, which provides the method by which packets are displayed during debugging. Fast switching may also be inappropriate when bringing traffic from high-speed interfaces to slower ones—this is one area where designers must understand not only the bandwidth potential of their links, but also the actual flow of traffic.

Fast switching guarantees that packets will be processed within16 processor cycles. Unlike process-switched packets, the router’s processor will not be interrupted to facilitate forwarding.

Autonomous Switching:-
Feature on Cisco routers that provides faster packet processing by allowing the ciscoBus to switch packets independently without interrupting the system processor.
Autonomous switching is comparable to fast switching. When a packet arrives on the interface processor, it checks the switching cache closest to it— the caches that reside on other processor boards. The packet is encapsulated for autonomous switching and sent back to the interface processor. The packet header is not sent to the route processor. Autonomous switching is available only on AGS+ and Cisco7000 series routers that have high-speed controller interface cards.

If you enable fast or autonomous switching on an interface, packets coming from any other interface on the router are fast-switched (or autonomous-switched) to that interface. If you enable same-interface fast or autonomous switching, packets whose source and destination address are the same are fast or autonomous switched.
You can use same-interface fast or autonomous switching in cases where you have Frame Relay or Asynchronous Transfer Mode (ATM) WAN links configured as subinterfaces on the same main interface. Another situation is when you are using secondary networks on LAN interfaces, as during IP address migration. In order to enable same-interface fast switching, you can use the ip route-cache same-interface command.

Deploying SEEDBOX using uTorrent on Ubuntu Server.

  • 0
Tools to be Downloaded:
------------------------------------------------------------------------------------------
1. http://www.mollify.org/downloads.php
2. http://www.utorrent.com/downloads/linux
------------------------------------------------------------------------------------------
------------------------------------------------------------------------------------------

Install uTorrent Server 3.3

Step 1: Download latest uTorrent Server from here

Note: (You need to download uTorrent Server for 13.04, also works for Ubuntu 14.04)

Step 2: Extract uTorrent Files

  • Launch terminal and change directory to Downloads folder
    cd Downloads/
    
  • Extract uTorrent files to the /opt directory
    sudo tar xvzf utserver.tar.gz -C /opt/
    

Step 3: Set Permission

  • Set permission on uTorrent-server folder
    sudo chmod -R 777 /opt/utorrent-server-alpha-v3_3/
    

Step 4: Set Symbolic link

  • Run the command to link uTorrent server to the /user/bin directory.
    sudo ln -s /opt/utorrent-server-alpha-v3_3/utserver /usr/bin/utserver
    

Step 5: Start uTorrent

utserver -settingspath /opt/utorrent-server-alpha-v3_3/
 
Note: If you get an error about libssl.so package missing or see utserver not starting, run the command below to install it, then try starting it again.

sudo apt-get install libssl0.9.8:i386

Step 6: Log into uTorrent

  • Open Firefox and browse to the URL
    localhost:8080/gui
    
  • The username is 'admin' and leave the password field empty.

    • Step 7: Modify /etc/rc.local for uTorrent to start at Boot:

      root@seedbox:~# cat /etc/rc.local
      #!/bin/sh -e
      #
      # rc.local
      #
      # This script is executed at the end of each multiuser runlevel.
      # Make sure that the script will "exit 0" on success or any other
      # value on error.
      #
      # In order to enable or disable this script just change the execution
      # bits.
      #
      # By default this script does nothing.
      /usr/bin/utserver -settingspath /opt/uts/ -daemon  -logfile /opt/uts/server.log
      su -l soham -c rtorrent
      exit 0
      root@seedbox:~#

Bridge ports in Cisco Routers

 

R1(config)# no ip routing. Enables bridging of IP packets. This command needs to be executed once per card, not once per bridge-group. This step is not done for integrated routing and bridging (IRB).
------------------------
bridge irb
 bridge-group 1
bridge 1 protocol ieee
------------------------

BANDEL#show run
Building configuration...

Current configuration : 1909 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname BANDEL
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip source-route
no ip icmp rate-limit unreachable
!
!
!
!
ip cef
no ip domain lookup
no ipv6 traffic interface-statistics
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
!
!
!
ip tcp synwait-time 5
bridge irb
!
!
!
!
interface Ethernet0/0
 description "BRIDGED"
 no ip address
 bridge-group 1
!
interface Ethernet0/1
 description "BRIDGED"
 no ip address
 bridge-group 1
!
interface Ethernet0/2
 description "BRIDGED"
 no ip address
 bridge-group 1
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Ethernet1/0
 no ip address
 shutdown
!
interface Ethernet1/1
 no ip address
 shutdown
!
interface Ethernet1/2
 no ip address
 shutdown
!
interface Ethernet1/3
 no ip address
 shutdown
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/3
 no ip address
 shutdown
 serial restart-delay 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
bridge 1 protocol ieee
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
exception data-corruption buffer truncate
end

BANDEL#


BURDWAN#show run
Building configuration...

Current configuration : 1910 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname BURDWAN
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip source-route
no ip icmp rate-limit unreachable
!
!
!
!
ip cef
no ip domain lookup
no ipv6 traffic interface-statistics
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
!
!
!
ip tcp synwait-time 5
bridge irb
!
!
!
!
interface Ethernet0/0
 description "BRIDGED"
 no ip address
 bridge-group 1
!
interface Ethernet0/1
 description "BRIDGED"
 no ip address
 bridge-group 1
!
interface Ethernet0/2
 description "BRIDGED"
 no ip address
 bridge-group 1
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Ethernet1/0
 no ip address
 shutdown
!
interface Ethernet1/1
 no ip address
 shutdown
!
interface Ethernet1/2
 no ip address
 shutdown
!
interface Ethernet1/3
 no ip address
 shutdown
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/3
 no ip address
 shutdown
 serial restart-delay 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
bridge 1 protocol ieee
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
exception data-corruption buffer truncate
end

BURDWAN#






PANDUA(config)#do ping 1.4.2.9 repeat 1

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 1.4.2.9, timeout is 2 seconds:
!
Success rate is 100 percent (1/1), round-trip min/avg/max = 1/1/1 ms
PANDUA(config)#do ping 1.4.2.9 repeat 1000

Type escape sequence to abort.
Sending 1000, 100-byte ICMP Echos to 1.4.2.9, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (1000/1000), round-trip min/avg/max = 1/1/4 ms
PANDUA(config)#





Designing a Core ISP Network

  • 0
-------------------------------------
root# show
## Last changed: 2019-04-04 20:12:37 UTC
version 12.1R1.9;
system {
    root-authentication {
        encrypted-password "$1$XrnazupP$IChYvM93l90W6b0GfMxNn/"; ## SECRET-DATA
    }
    services {
        ssh;
        telnet;
    }
    syslog {
        user * {
            any emergency;
        }
        file messages {
            any notice;
            authorization info;
        }
        file interactive-commands {
            interactive-commands any;
        }
    }
}
interfaces {
    em0 {
        vlan-tagging;
        unit 0 {
            vlan-id 10;
            family inet {
                address 1.1.0.1/30;
            }
        }
    }
    em1 {
        unit 0 {
            description AIRTEL;
            family inet {
                address 1.2.0.6/30;
            }
        }
    }
    em2 {
        unit 0 {
            description FLIPKART;
            family inet {
                address 1.1.2.1/30;
            }
        }
    }
}
routing-options {
    static {
        route 1.1.0.0/24 discard;
        route 1.1.1.0/24 discard;
        route 1.1.2.0/24 discard;
        route 1.1.3.0/24 discard;
        route 1.1.1.0/30 next-hop 1.1.0.2;
    }
    router-id 1.1.0.1;
}
protocols {
    bgp {
        local-as 1100;
        group TATA {
            export TATA_OUT;
            peer-as 1100;
            neighbor 1.1.0.2;
        }
        group AIRTEL {
            export TATA_OUT;
            peer-as 1200;
            neighbor 1.2.0.5;
        }
        group FLIPKART {
            export TATA_OUT;
            peer-as 1500;
            neighbor 1.1.2.2;
        }
    }
}
policy-options {
    prefix-list TATA_OUT {
        1.1.0.0/24;
        1.1.1.0/24;
        1.1.3.0/24;
        1.1.4.0/24;
    }
    policy-statement TATA_OUT {
        term 1 {
            from {
                prefix-list TATA_OUT;
            }
            then accept;
        }
        term 3 {
            from protocol direct;
            then accept;
        }
        term 2 {
            from protocol bgp;
            then accept;
        }
    }
}

    [edit]
root#

[edit]
root#

[edit]
root# set system host-name TATA_US

[edit]
root# commit
commit complete

[edit]
root@TATA_US# show
## Last changed: 2019-04-04 20:33:34 UTC
version 12.1R1.9;
system {
    host-name TATA_US;
    root-authentication {
        encrypted-password "$1$XrnazupP$IChYvM93l90W6b0GfMxNn/"; ## SECRET-DATA
    }
    services {
        ssh;
        telnet;
    }
    syslog {
        user * {
            any emergency;
        }
        file messages {
            any notice;
            authorization info;
        }
        file interactive-commands {
            interactive-commands any;
        }
    }
}
interfaces {
    em0 {
        vlan-tagging;
        unit 0 {
            vlan-id 10;
            family inet {
                address 1.1.0.1/30;
            }
        }
    }
    em1 {
        unit 0 {
            description AIRTEL;
            family inet {
                address 1.2.0.6/30;
            }
        }
    }
    em2 {
        unit 0 {
            description FLIPKART;
            family inet {
                address 1.1.2.1/30;
            }
        }
    }
}
routing-options {
    static {
        route 1.1.0.0/24 discard;
        route 1.1.1.0/24 discard;
        route 1.1.2.0/24 discard;
        route 1.1.3.0/24 discard;
        route 1.1.1.0/30 next-hop 1.1.0.2;
    }
    router-id 1.1.0.1;
}
protocols {
    bgp {
        local-as 1100;
        group TATA {
            export TATA_OUT;
            peer-as 1100;
            neighbor 1.1.0.2;
        }
        group AIRTEL {
            export TATA_OUT;
            peer-as 1200;
            neighbor 1.2.0.5;
        }
        group FLIPKART {
            export TATA_OUT;
            peer-as 1500;
            neighbor 1.1.2.2;
        }
    }
}
policy-options {
    prefix-list TATA_OUT {
        1.1.0.0/24;
        1.1.1.0/24;
        1.1.3.0/24;
        1.1.4.0/24;
    }
    policy-statement TATA_OUT {
        term 1 {
            from {
                prefix-list TATA_OUT;
            }
            then accept;
        }
        term 3 {
            from protocol direct;
            then accept;
        }
        term 2 {
            from protocol bgp;
            then accept;
        }
    }
}

[edit]
root@TATA_US#


root@TATA_US# run show route

inet.0: 27 destinations, 35 routes (27 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

1.1.0.0/24         *[Static/5] 00:20:48
                      Discard
1.1.0.0/30         *[Direct/0] 00:00:18
                    > via em0.0
1.1.0.1/32         *[Local/0] 00:00:18
                      Local via em0.0
1.1.1.0/24         *[Static/5] 00:20:48
                      Discard
1.1.1.0/30         *[Static/5] 00:20:46
                    > to 1.1.0.2 via em0.0
1.1.2.0/24         *[Static/5] 00:20:48
                      Discard
1.1.2.0/30         *[Direct/0] 00:20:42
                    > via em2.0
1.1.2.1/32         *[Local/0] 00:20:43
                      Local via em2.0
1.1.3.0/24         *[Static/5] 00:20:48
                      Discard
1.2.0.0/24         *[BGP/170] 00:20:39, MED 0, localpref 100
                      AS path: 1200 I
                    > to 1.2.0.5 via em1.0
1.2.0.4/30         *[Direct/0] 00:20:43
                    > via em1.0
1.2.0.6/32         *[Local/0] 00:20:44
                      Local via em1.0
1.2.1.0/24         *[BGP/170] 00:20:39, MED 0, localpref 100
                      AS path: 1200 I
                    > to 1.2.0.5 via em1.0
1.2.2.0/24         *[BGP/170] 00:20:39, MED 0, localpref 100
                      AS path: 1200 I
                    > to 1.2.0.5 via em1.0
1.2.3.0/24         *[BGP/170] 00:20:39, MED 0, localpref 100
                      AS path: 1200 I
                    > to 1.2.0.5 via em1.0
1.3.0.0/24         *[BGP/170] 00:20:37, localpref 100
                      AS path: 1300 I
                    > to 1.1.0.2 via em0.0
                    [BGP/170] 00:20:39, localpref 100
   
-------------------------------------

root> configure
Entering configuration mode

[edit]
root# set system host-name TATA_INDIA

[edit]
root# commit
commit complete

[edit]
root@TATA_INDIA# show
## Last changed: 2019-04-04 20:34:43 UTC
version 12.1R1.9;
system {
    host-name TATA_INDIA;
    root-authentication {
        encrypted-password "$1$QyYhErAK$Ovn/xeO20OoDNKpmKi81T."; ## SECRET-DATA
    }
    syslog {
        user * {
            any emergency;
        }
        file messages {
            any notice;
            authorization info;
        }
        file interactive-commands {
            interactive-commands any;
        }
    }
}
interfaces {
    em0 {
        vlan-tagging;
        unit 0 {
            vlan-id 10;
            family inet {
                address 1.1.0.2/30;
            }
        }
    }
    em1 {
        vlan-tagging;
        unit 0 {
            vlan-id 20;
            family inet {
                address 1.1.1.1/30;
            }
        }
    }
}
routing-options {
    router-id 1.1.1.1;
}
protocols {
    bgp {
        local-as 1100;
        group TATA {
            type internal;
            peer-as 1100;
            neighbor 1.1.0.1;
        }
        group IKF {
            type external;
            peer-as 1300;
            neighbor 1.2.0.1;
            neighbor 1.1.1.2;
        }
    }
}

[edit]
root@TATA_INDIA# run show route receive-protocol bgp 1.1.0.1

inet.0: 25 destinations, 26 routes (25 active, 0 holddown, 0 hidden)
  Prefix                  Nexthop              MED     Lclpref    AS path
* 1.1.0.0/24              1.1.0.1                      100        I
  1.1.0.0/30              1.1.0.1                      100        I
* 1.1.1.0/24              1.1.0.1                      100        I
* 1.1.2.0/30              1.1.0.1                      100        I
* 1.1.3.0/24              1.1.0.1                      100        I
* 1.2.0.0/24              1.2.0.5              0       100        1200 I
* 1.2.0.4/30              1.1.0.1                      100        I
* 1.2.1.0/24              1.2.0.5              0       100        1200 I
* 1.2.2.0/24              1.2.0.5              0       100        1200 I
* 1.2.3.0/24              1.2.0.5              0       100        1200 I
* 1.3.0.0/24              1.2.0.5                      100        1200 1300 I
* 1.3.1.0/24              1.2.0.5                      100        1200 1300 I
* 1.3.2.0/24              1.2.0.5                      100        1200 1300 I
* 1.3.3.0/24              1.2.0.5                      100        1200 1300 I
* 1.4.0.0/24              1.2.0.5                      100        1200 1300 1400 I
* 1.4.1.0/24              1.2.0.5                      100        1200 1300 1400 I
* 1.4.2.0/24              1.2.0.5                      100        1200 1300 1400 I
* 1.4.3.0/24              1.2.0.5                      100        1200 1300 1400 I
* 1.5.0.0/24              1.1.2.2                      100        1500 I
* 1.5.1.0/24              1.1.2.2                      100        1500 I
* 1.5.2.0/24              1.1.2.2                      100        1500 I
* 1.5.3.0/24              1.1.2.2                      100        1500 I

[edit]
root@TATA_INDIA#

-------------------------------------

root@FLIPKART# show
## Last changed: 2019-04-04 20:44:18 UTC
version 10.1R1.8;
system {
    host-name FLIPKART;
    root-authentication {
        encrypted-password "$1$VaEmnu16$W15FJXKTptT3u/6ie4iNe1"; ## SECRET-DATA
    }
    syslog {
        user * {
            any emergency;
        }
        file messages {
            any notice;
            authorization info;
        }
        file interactive-commands {
            interactive-commands any;
        }
    }
}
interfaces {
    em0 {
        unit 0 {
            description TATA_US;
            family inet {
                address 1.1.2.2/30;
            }
        }
    }
    em2 {
        unit 0 {
            description FLIPKART_HEADOFFICE;
            family inet {
                address 1.5.1.1/30;
            }
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 1.5.0.1/32;
            }
        }
    }
}
routing-options {
    static {
        route 1.5.0.0/24 discard;
        route 1.5.1.0/24 discard;
        route 1.5.2.0/24 discard;
        route 1.5.3.0/24 discard;
    }
}
protocols {
    bgp {
        local-as 1500;
        group TATA_US {
            export TATA_US_OUT;
            peer-as 1100;
            neighbor 1.1.2.1;
        }
    }
}
policy-options {
    policy-statement TATA_US_OUT {
        term 1 {
            from {
                route-filter 1.5.0.0/24 exact;
                route-filter 1.5.1.0/24 exact;
                route-filter 1.5.2.0/24 exact;
                route-filter 1.5.3.0/24 exact;
            }
            then accept;
        }
    }
}

[edit]
root@FLIPKART#

-------------------------------------


FLIPKART_HEADOFFICE(config)#do show run
Building configuration...

Current configuration : 1928 bytes
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname FLIPKART_HEADOFFICE
!
boot-start-marker
boot-end-marker
!
!
logging discriminator EXCESS severity drops 6 msg-body drops EXCESSCOLL
logging buffered 50000
logging console discriminator EXCESS
!
no aaa new-model
no ip icmp rate-limit unreachable
!
ip cef
!
ip dhcp pool 192.168.0.x
 network 192.168.0.0 255.255.255.0
 default-router 192.168.0.1
 dns-server 192.168.0.1
 lease 0 23
!
!
no ip domain-lookup
no ipv6 cef
ipv6 multicast rpf use-bgp
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
!
!
vlan internal allocation policy ascending
!
ip tcp synwait-time 5
!
!
!
!
interface Tunnel0
 ip address 172.16.1.1 255.255.255.252
 ip mtu 1400
 ip tcp adjust-mss 1360
 tunnel source Ethernet0/0
 tunnel destination 1.4.1.2
!
interface Ethernet0/0
 description "FLIPCART CORE"
 no switchport
 ip address 1.5.1.2 255.255.255.252
!
interface Ethernet0/1
 no switchport
 ip address 192.168.0.1 255.255.255.0
!
interface Ethernet0/2
 duplex auto
!
interface Ethernet0/3
 duplex auto
!
interface Ethernet1/0
 duplex auto
!
interface Ethernet1/1
 duplex auto
!
interface Ethernet1/2
 duplex auto
!
interface Ethernet1/3
 duplex auto
!
interface Ethernet2/0
 duplex auto
!
interface Ethernet2/1
 duplex auto
!
interface Ethernet2/2
 duplex auto
!
interface Ethernet2/3
 duplex auto
!
interface Ethernet3/0
 duplex auto
!
interface Ethernet3/1
 duplex auto
!
interface Ethernet3/2
 duplex auto
!
interface Ethernet3/3
 duplex auto
!
interface Vlan1
 no ip address
 shutdown
!
!
!
no ip http server
ip route 0.0.0.0 0.0.0.0 1.5.1.1
ip route 192.168.1.0 255.255.255.0 Tunnel0
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
end

FLIPKART_HEADOFFICE(config)#


FLIPKART_HEADOFFICE(config)#do show ip rou
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 1.5.1.1 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 1.5.1.1
      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.5.1.0/30 is directly connected, Ethernet0/0
L        1.5.1.2/32 is directly connected, Ethernet0/0
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.1.0/30 is directly connected, Tunnel0
L        172.16.1.1/32 is directly connected, Tunnel0
      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, Ethernet0/1
L        192.168.0.1/32 is directly connected, Ethernet0/1
S     192.168.1.0/24 is directly connected, Tunnel0
FLIPKART_HEADOFFICE(config)#


FLIPKART_HEADOFFICE(config)#do show ip dhcp binding
Bindings from all pools not associated with VRF:
IP address          Client-ID/              Lease expiration        Type
                    Hardware address/
                    User name
192.168.0.2         0063.6973.636f.2d61.    Apr 05 2019 07:40 PM    Automatic
                    6162.622e.6363.3030.
                    2e30.3430.302d.4574.
                    302f.30
FLIPKART_HEADOFFICE(config)#



-------------------------------------

FLIPKART_BRANCH(config)#do show run
Building configuration...

Current configuration : 1935 bytes
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname FLIPKART_BRANCH
!
boot-start-marker
boot-end-marker
!
!
logging discriminator EXCESS severity drops 6 msg-body drops EXCESSCOLL
logging buffered 50000
logging console discriminator EXCESS
!
no aaa new-model
no ip icmp rate-limit unreachable
!
ip cef
!
ip dhcp pool 192.168.1.x
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.1
 dns-server 192.168.1.1
 lease 0 23
!
!
no ip domain-lookup
no ipv6 cef
ipv6 multicast rpf use-bgp
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
!
!
vlan internal allocation policy ascending
!
ip tcp synwait-time 5
!
!
!
!
interface Tunnel0
 ip address 172.16.1.2 255.255.255.252
 ip mtu 1400
 ip tcp adjust-mss 1360
 tunnel source Ethernet0/0
 tunnel destination 1.5.1.2
!
interface Ethernet0/0
 description "WEFE"
 no switchport
 ip address 1.4.1.2 255.255.255.252
!
interface Ethernet0/1
 description "DHCP"
 no switchport
 ip address 192.168.1.1 255.255.255.0
!
interface Ethernet0/2
 duplex auto
!
interface Ethernet0/3
 duplex auto
!
interface Ethernet1/0
 duplex auto
!
interface Ethernet1/1
 duplex auto
!
interface Ethernet1/2
 duplex auto
!
interface Ethernet1/3
 duplex auto
!
interface Ethernet2/0
 duplex auto
!
interface Ethernet2/1
 duplex auto
!
interface Ethernet2/2
 duplex auto
!
interface Ethernet2/3
 duplex auto
!
interface Ethernet3/0
 duplex auto
!
interface Ethernet3/1
 duplex auto
!
interface Ethernet3/2
 duplex auto
!
interface Ethernet3/3
 duplex auto
!
interface Vlan1
 no ip address
 shutdown
!
!
!
no ip http server
ip route 0.0.0.0 0.0.0.0 1.4.1.1
ip route 192.168.0.0 255.255.255.0 Tunnel0
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
end
-------------------------------------

AIRTEL#show run
Building configuration...

Current configuration : 2943 bytes
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname AIRTEL
!
boot-start-marker
boot-end-marker
!
!
logging discriminator EXCESS severity drops 6 msg-body drops EXCESSCOLL
logging buffered 50000
logging console discriminator EXCESS
!
no aaa new-model
no ip icmp rate-limit unreachable
!
ip cef
!
!
no ip domain-lookup
no ipv6 cef
ipv6 multicast rpf use-bgp
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
!
!
vlan internal allocation policy ascending
!
ip tcp synwait-time 5
!
!
!
!
interface Ethernet0/0
 description "IKF"
 no switchport
 ip address 1.2.0.1 255.255.255.252
!
interface Ethernet0/1
 description "TATA_US"
 no switchport
 ip address 1.2.0.5 255.255.255.252
!
interface Ethernet0/2
 duplex auto
!
interface Ethernet0/3
 duplex auto
!
interface Ethernet1/0
 duplex auto
!
interface Ethernet1/1
 duplex auto
!
interface Ethernet1/2
 duplex auto
!
interface Ethernet1/3
 duplex auto
!
interface Ethernet2/0
 duplex auto
!
interface Ethernet2/1
 duplex auto
!
interface Ethernet2/2
 duplex auto
!
interface Ethernet2/3
 duplex auto
!
interface Ethernet3/0
 duplex auto
!
interface Ethernet3/1
 duplex auto
!
interface Ethernet3/2
 duplex auto
!
interface Ethernet3/3
 duplex auto
!
interface Serial4/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial4/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial4/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial4/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial5/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial5/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial5/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial5/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Vlan1
 no ip address
 shutdown
!
router bgp 1200
 bgp log-neighbor-changes
 network 1.2.0.0 mask 255.255.255.0
 network 1.2.1.0 mask 255.255.255.0
 network 1.2.2.0 mask 255.255.255.0
 network 1.2.3.0 mask 255.255.255.0
 neighbor 1.2.0.2 remote-as 1300
 neighbor 1.2.0.2 description IKF
 neighbor 1.2.0.2 route-map IKF_OUT out
 neighbor 1.2.0.6 remote-as 1100
 neighbor 1.2.0.6 description "TATA_US"
!
!
!
no ip http server
ip route 1.2.0.0 255.255.255.0 Null0
ip route 1.2.1.0 255.255.255.0 Null0
ip route 1.2.2.0 255.255.255.0 Null0
ip route 1.2.3.0 255.255.255.0 Null0
!
!
ip prefix-list TO_IKF seq 1 permit 1.2.0.0/24
ip prefix-list TO_IKF seq 2 permit 1.2.1.0/24
ip prefix-list TO_IKF seq 3 permit 1.2.2.0/24
ip prefix-list TO_IKF seq 4 permit 1.2.3.0/24
!
route-map IKF_OUT permit 0
 match ip address prefix-list TO_IKF
 set as-path prepend 1200 1200 1200
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
end

AIRTEL#
-------------------------------------

[admin@IKF_CORE] > export
# apr/04/2019 20:59:14 by RouterOS 6.44.1
# software id =
#
#
#
/interface vlan
add comment=TATA interface=ether1 name=TATA_INDIA vlan-id=20
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/queue tree
add max-limit=3M name=GLOBAL packet-mark=TATA parent=global
add max-limit=1500k name=TATA_IN packet-mark=TATA_IN parent=GLOBAL
add max-limit=1500k name=TATA_OUT packet-mark=TATA_OUT parent=GLOBAL
/routing bgp instance
set default as=1300 router-id=1.3.0.1
/ip address
add address=192.168.125.1/24 comment=MGMT interface=ether12 network=192.168.125.0
add address=1.1.1.2/30 comment=TATA interface=TATA_INDIA network=1.1.1.0
add address=1.3.1.1/30 comment=WEFE interface=ether2 network=1.3.1.0
add address=1.2.0.2/30 comment=AIRTEL interface=ether3 network=1.2.0.0
/ip dhcp-client
add disabled=no interface=ether1
/ip firewall mangle
add action=mark-packet chain=forward in-interface=TATA_INDIA new-packet-mark=TATA packet-mark=no-mark passthrough=yes
add action=mark-packet chain=forward dst-port=80,443 new-packet-mark=TATA_OUT packet-mark=TATA passthrough=yes protocol=tcp
add action=mark-packet chain=forward dst-port=2000 new-packet-mark=TATA_OUT packet-mark=TATA passthrough=yes protocol=udp
add action=mark-packet chain=forward new-packet-mark=TATA_IN packet-mark=TATA passthrough=yes protocol=tcp src-port=80,443
add action=mark-packet chain=forward new-packet-mark=TATA_IN packet-mark=TATA passthrough=yes protocol=udp src-port=2000
/routing bgp network
add network=1.3.0.0/24 synchronize=no
add network=1.3.1.0/24 synchronize=no
add network=1.3.2.0/24 synchronize=no
add network=1.3.3.0/24 synchronize=no
/routing bgp peer
add in-filter=TATA_IN name=TATA_INDIA out-filter=TATA_OUT remote-address=1.1.1.1 remote-as=1100 ttl=default
add default-originate=always in-filter=WEFE_IN name=WEFE out-filter=WEFE_OUT remote-address=1.3.1.2 remote-as=1400 ttl=default
add in-filter=AIRTEL_IN name=AIRTEL out-filter=AIRTEL_OUT remote-address=1.2.0.1 remote-as=1200 ttl=default
/routing filter
add action=accept chain=TATA_IN
add action=log chain=TATA_IN
add action=accept chain=TATA_OUT prefix=1.3.0.0/24 prefix-length=0-128
add action=accept chain=TATA_OUT prefix=1.3.2.0/24 prefix-length=0-128
add action=accept chain=TATA_OUT prefix=1.3.3.0/24 prefix-length=0-128
add action=accept chain=TATA_OUT prefix=1.3.1.0/24 prefix-length=0-128
add action=accept chain=TATA_OUT comment=WEFE prefix=1.4.1.0/24
add action=accept chain=TATA_OUT comment=WEFE prefix=1.4.2.0/24
add action=accept chain=TATA_OUT comment=WEFE prefix=1.4.3.0/24
add action=accept chain=TATA_OUT comment=WEFE prefix=1.4.0.0/24
add action=discard chain=TATA_OUT
add action=log chain=TATA_OUT
/system identity
set name=IKF_CORE
[admin@IKF_CORE] >

[admin@IKF_CORE] > ip route print
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADb  1.1.0.0/24                         1.1.1.1                  20
 1 ADb  1.1.1.0/24                         1.1.1.1                  20
 2 ADC  1.1.1.0/30         1.1.1.2         TATA_INDIA                0
 3 ADb  1.1.2.0/30                         1.1.1.1                  20
 4 ADb  1.1.3.0/24                         1.1.1.1                  20
 5 ADb  1.2.0.0/24                         1.1.1.1                  20
 6  Db  1.2.0.0/24                         1.2.0.1                  20
 7 ADC  1.2.0.0/30         1.2.0.2         ether3                    0
 8 ADb  1.2.0.4/30                         1.1.1.1                  20
 9 ADb  1.2.1.0/24                         1.1.1.1                  20
10  Db  1.2.1.0/24                         1.2.0.1                  20
11 ADb  1.2.2.0/24                         1.1.1.1                  20
12  Db  1.2.2.0/24                         1.2.0.1                  20
13 ADb  1.2.3.0/24                         1.1.1.1                  20
14  Db  1.2.3.0/24                         1.2.0.1                  20
15 ADC  1.3.1.0/30         1.3.1.1         ether2                    0
16 ADb  1.4.0.0/24                         1.3.1.2                  20
17 ADb  1.4.1.0/24                         1.3.1.2                  20
18 ADb  1.4.2.0/24                         1.3.1.2                  20
19 ADb  1.4.3.0/24                         1.3.1.2                  20
20 ADb  1.5.0.0/24                         1.1.1.1                  20
21 ADb  1.5.1.0/24                         1.1.1.1                  20
22 ADb  1.5.2.0/24                         1.1.1.1                  20
23 ADb  1.5.3.0/24                         1.1.1.1                  20
24 ADC  192.168.125.0/24   192.168.125.1   ether12                   0
[admin@IKF_CORE] >

-------------------------------------
[admin@WEFE] > export
# apr/04/2019 21:00:04 by RouterOS 6.44.1
# software id =
#
#
#
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/routing bgp instance
set default as=1400
/ip address
add address=192.168.125.2/24 comment=MGMT interface=ether12 network=192.168.125.0
add address=1.3.1.2/30 comment=IKF interface=ether1 network=1.3.1.0
add address=1.4.1.1/30 comment=FLIPKART_BRANCH interface=ether2 network=1.4.1.0
/ip dhcp-client
add disabled=no interface=ether1
/ip route
add distance=1 gateway=1.3.1.1
/routing bgp network
add network=1.4.0.0/24 synchronize=no
add network=1.4.1.0/24 synchronize=no
add network=1.4.2.0/24 synchronize=no
add network=1.4.3.0/24 synchronize=no
/routing bgp peer
add in-filter=IKF_IN name=IKF out-filter=IKF_OUT remote-address=1.3.1.1 remote-as=1300 ttl=default
/routing filter
add action=accept chain=IKF_IN disabled=yes prefix=0.0.0.0/0
add action=discard chain=IKF_IN disabled=yes
add action=accept chain=IKF_OUT disabled=yes
/system identity
set name=WEFE
[admin@WEFE] >

[admin@WEFE] > ip route print
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 A S  0.0.0.0/0                          1.3.1.1                   1
 1  Db  0.0.0.0/0                          1.3.1.1                  20
 2 ADb  1.1.0.0/24                         1.3.1.1                  20
 3 ADb  1.1.1.0/24                         1.3.1.1                  20
 4 ADb  1.1.2.0/30                         1.3.1.1                  20
 5 ADb  1.1.3.0/24                         1.3.1.1                  20
 6 ADb  1.2.0.0/24                         1.3.1.1                  20
 7 ADb  1.2.0.4/30                         1.3.1.1                  20
 8 ADb  1.2.1.0/24                         1.3.1.1                  20
 9 ADb  1.2.2.0/24                         1.3.1.1                  20
10 ADb  1.2.3.0/24                         1.3.1.1                  20
11 ADb  1.3.0.0/24                         1.3.1.1                  20
12 ADb  1.3.1.0/24                         1.3.1.1                  20
13 ADC  1.3.1.0/30         1.3.1.2         ether1                    0
14 ADb  1.3.2.0/24                         1.3.1.1                  20
15 ADb  1.3.3.0/24                         1.3.1.1                  20
16 ADC  1.4.1.0/30         1.4.1.1         ether2                    0
17 ADb  1.5.0.0/24                         1.3.1.1                  20
18 ADb  1.5.1.0/24                         1.3.1.1                  20
19 ADb  1.5.2.0/24                         1.3.1.1                  20
20 ADb  1.5.3.0/24                         1.3.1.1                  20
21 ADC  192.168.125.0/24   192.168.125.2   ether12                   0
[admin@WEFE] >

-------------------------------------


FLIPKART_BRANCH(config)#
FLIPKART_BRANCH(config)#do show run
Building configuration...

Current configuration : 1935 bytes
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname FLIPKART_BRANCH
!
boot-start-marker
boot-end-marker
!
!
logging discriminator EXCESS severity drops 6 msg-body drops EXCESSCOLL
logging buffered 50000
logging console discriminator EXCESS
!
no aaa new-model
no ip icmp rate-limit unreachable
!
ip cef
!
ip dhcp pool 192.168.1.x
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.1
 dns-server 192.168.1.1
 lease 0 23
!
!
no ip domain-lookup
no ipv6 cef
ipv6 multicast rpf use-bgp
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
!
!
vlan internal allocation policy ascending
!
ip tcp synwait-time 5
!
!
!
!
interface Tunnel0
 ip address 172.16.1.2 255.255.255.252
 ip mtu 1400
 ip tcp adjust-mss 1360
 tunnel source Ethernet0/0
 tunnel destination 1.5.1.2
!
interface Ethernet0/0
 description "WEFE"
 no switchport
 ip address 1.4.1.2 255.255.255.252
!
interface Ethernet0/1
 description "DHCP"
 no switchport
 ip address 192.168.1.1 255.255.255.0
!
interface Ethernet0/2
 duplex auto
!
interface Ethernet0/3
 duplex auto
!
interface Ethernet1/0
 duplex auto
!
interface Ethernet1/1
 duplex auto
!
interface Ethernet1/2
 duplex auto
!
interface Ethernet1/3
 duplex auto
!
interface Ethernet2/0
 duplex auto
!
interface Ethernet2/1
 duplex auto
!
interface Ethernet2/2
 duplex auto
!
interface Ethernet2/3
 duplex auto
!
interface Ethernet3/0
 duplex auto
!
interface Ethernet3/1
 duplex auto
!
interface Ethernet3/2
 duplex auto
!
interface Ethernet3/3
 duplex auto
!
interface Vlan1
 no ip address
 shutdown
!
!
!
no ip http server
ip route 0.0.0.0 0.0.0.0 1.4.1.1
ip route 192.168.0.0 255.255.255.0 Tunnel0
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
end

FLIPKART_BRANCH(config)#

-------------------------------------

NODE1#
NODE1#show run
Building configuration...

Current configuration : 1581 bytes
!
! Last configuration change at 20:41:14 UTC Thu Apr 4 2019
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname NODE1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
ip cef
no ip domain-lookup
!
no ipv6 cef
!
!
ip tcp synwait-time 5
!
!
!
!
interface Ethernet0/0
 ip address dhcp
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Ethernet1/0
 no ip address
 shutdown
!
interface Ethernet1/1
 no ip address
 shutdown
!
interface Ethernet1/2
 no ip address
 shutdown
!
interface Ethernet1/3
 no ip address
 shutdown
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
ip forward-protocol nd
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
 transport input all
!
end

NODE1#

-------------------------------------

NODE2#
NODE2#show run
Building configuration...

Current configuration : 1581 bytes
!
! Last configuration change at 21:03:09 UTC Thu Apr 4 2019
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname NODE2
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
ip cef
no ip domain-lookup
!
no ipv6 cef
!
!
ip tcp synwait-time 5
!
!
!
!
interface Ethernet0/0
 ip address dhcp
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Ethernet1/0
 no ip address
 shutdown
!
interface Ethernet1/1
 no ip address
 shutdown
!
interface Ethernet1/2
 no ip address
 shutdown
!
interface Ethernet1/3
 no ip address
 shutdown
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
ip forward-protocol nd
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
 transport input all
!
end

NODE2#

NODE2#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
Ethernet0/0            192.168.1.2     YES DHCP   up                    up
Ethernet0/1            unassigned      YES NVRAM  administratively down down
Ethernet0/2            unassigned      YES NVRAM  administratively down down
Ethernet0/3            unassigned      YES NVRAM  administratively down down
Ethernet1/0            unassigned      YES NVRAM  administratively down down
Ethernet1/1            unassigned      YES NVRAM  administratively down down
Ethernet1/2            unassigned      YES NVRAM  administratively down down
Ethernet1/3            unassigned      YES NVRAM  administratively down down
Serial2/0              unassigned      YES NVRAM  administratively down down
Serial2/1              unassigned      YES NVRAM  administratively down down
Serial2/2              unassigned      YES NVRAM  administratively down down
Serial2/3              unassigned      YES NVRAM  administratively down down
Serial3/0              unassigned      YES NVRAM  administratively down down
Serial3/1              unassigned      YES NVRAM  administratively down down
Serial3/2              unassigned      YES NVRAM  administratively down down
Serial3/3              unassigned      YES NVRAM  administratively down down

NODE2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 192.168.1.1 to network 0.0.0.0

S*    0.0.0.0/0 [254/0] via 192.168.1.1
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, Ethernet0/0
L        192.168.1.2/32 is directly connected, Ethernet0/0
NODE2#

-------------------------------------